All Collections
Troubleshooting
iOS
iPhone and iPad compatible
iPhone and iPad compatible

Is Rogervoice compatible with my iPhone?

Updated over a week ago

📱 To access the next updates for Rogervoice (patches or new functions), you must have at least iOS version 15.0 on your iPhone or iPad.

  • iPhone compatible with iOS 15 : iPhone SE, iPhone 6s, iPhone 6s Plus, iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8 Plus, iPhone X, iPhone XR, iPhone XS, iPhone XS Max, iPhone 11, iPhone 11 Pro et 11 Pro Max, iPhone 12, iPhone 12 Mini, iPhone 12 Pro, iPhone 12 Pro Max, iPhone 13, iPhone 13 Mini, iPhone 13 Pro, iPhone 13 Pro Max, iPhone 14, iPhone 14 Plus, iPhone 14 Pro, iPhone 14 Pro Max, iPhone 15, iPhone 15 Plus, iPhone 15 Pro, iPhone 15 Pro Max.

  • iPad compatible with iOS 15 : iPad Mini 4, iPad Air 2, iPad Air 3, iPad 5, iPad 6, iPad Pro, and more recent iPad models

    To update to the newest version 👉🏼 https://support.apple.com/en-us/HT204204

Before updating your telephone/tablet, we suggest that you backup your data

If you want to buy a new iPhone, we recommend:

  • iPhone SE

  • iPhone 14 / 14 Pro

  • iPhone 15 / 15 Pro

For more information, contact us via the app 😊
The Rogervoice team

Did this answer your question?